请选择 进入手机版 | 继续访问电脑版

 找回密码
 初始化身份识别芯片
查看: 132017|回复: 65

【0.97*】MagicLib 1.4.0*

    [复制链接]

势力巨擘

远星汉化组成员译码专家

Mod译者

发表于 2021-12-12 23:14:39 | 显示全部楼层 |阅读模式
汉化Mod发布
MagicLib 版本:1.4.0* Mod标识符:MagicLib
MagicLib
为Modder提供的开源脚本和插件
Mod作者: Tartiflette, Wisp
Mod译者: ASIIark
Mod类别: 前置
Mod适用版本: 0.97 0.96 0.95.1 
Mod更新时间: 2023-07-16
Mod发布地址: https://fractalsoftworks.com/forum/index.php?topic=25868.0
可安全移除:
依赖Mod: LazyLib 
其它依赖Mod:
冲突Mod:
Mod下载地址:
网盘提取码 / 解压密码:
本帖最后由 ASIIark 于 2024-2-25 21:45 编辑


汉化为论坛独占,禁止上传至别处或提供其它下载来源


详情英文版以及更早版本的文件见Jn大佬的原帖



0.40及其以后的更新会有汉化是因为Mod内提供了 Magic赏金框架 以及 HVB框架
原作者/现任维护者同时提供了包含一系列原版内容赏金的附加包 Lock and Loaded

从1.3.9开始实装了成就和涂装框架,但本前置不自带这方面内容
MagicLib现任维护者以及几位画手提供了一个 原版成就和涂装附加包

0.97a
MagicLib 1.4.0.zip (2.13 MB, 下载次数: 42793)
这个也稍微汉化了一下,里面有30+成就和20+涂装
MagicLib 原版成就包.zip (2.07 MB, 下载次数: 184)

0.96a
MagicLib 1.2.0.zip (1.44 MB, 下载次数: 2048)

0.95.1a
MagicLib 0.46.1-RC3.zip (979.6 KB, 下载次数: 18823)


汉化过程中可能出现失误,如有 缺漏 / 报错 请向我反馈
感谢Tart和Wisp提供的将该MOD上传至中文论坛的许可




战列舰长

垃圾佬

发表于 2021-12-12 23:27:14 来自手机 | 显示全部楼层
最速传说

战列舰长

发表于 2021-12-13 00:46:35 | 显示全部楼层
你是什么传奇

势力巨擘

发表于 2021-12-13 11:53:28 来自手机 | 显示全部楼层
这是什么情况!

势力巨擘

发表于 2021-12-13 11:54:14 来自手机 | 显示全部楼层
现在前置mod也要内置悬赏功能了吗。。。卷的这么厉害

战列舰长

发表于 2021-12-13 23:07:54 | 显示全部楼层
大佬的肝就是不一样

战列舰长

发表于 2021-12-13 23:58:51 | 显示全部楼层
多谢分享

战列舰长

发表于 2021-12-15 04:07:48 | 显示全部楼层
截图2.png
开新档游戏会崩溃

点评

好像是其他mod的问题,和seeker船包冲突,上一个版本的magic和seeker能正常游戏,更新magic也能读取之前开的存档,但是开新档就会崩溃,真是怪  详情 回复 发表于 2021-12-15 04:37

战列舰长

发表于 2021-12-15 04:37:07 | 显示全部楼层

好像是其他mod的问题,和seeker船包冲突,上一个版本的magic和seeker能正常游戏,更新magic也能读取之前开的存档,但是开新档就会崩溃,真是怪

战列舰长

发表于 2021-12-15 05:15:36 | 显示全部楼层
去外网论坛看了下Magic的mod制作者在今天凌晨1点半发了热修复RC2,修复了几个导致崩溃的问题,以及seeker我也更新最新,崩溃问题没了

战列舰长

发表于 2022-1-6 00:51:07 | 显示全部楼层
我这有个很神奇的问题,我是0.95版本的,下载0.34版本的magic就直接报错,反而这个0.40的能用,然而装这个0.40的跟seek这个mod冲突,不知道什么鬼

点评

测试了一下,跟恶魔航电也是冲突的  详情 回复 发表于 2022-1-6 01:03

战列舰长

发表于 2022-1-6 01:03:55 | 显示全部楼层
素鸡长毛 发表于 2022-1-6 00:51
我这有个很神奇的问题,我是0.95版本的,下载0.34版本的magic就直接报错,反而这个0.40的能用,然而装这个0 ...

测试了一下,跟恶魔航电也是冲突的

驱逐技师

发表于 2022-1-29 22:44:55 | 显示全部楼层
oy

驱逐技师

发表于 2022-3-2 14:49:46 | 显示全部楼层
不错

战列舰长

发表于 2022-3-24 22:52:43 | 显示全部楼层
多谢分享

巡洋大副

发表于 2022-4-11 23:13:48 | 显示全部楼层
0.0

驱逐技师

发表于 2022-4-17 22:09:31 | 显示全部楼层
谢谢

巡洋大副

发表于 2022-4-28 10:11:30 | 显示全部楼层
辛苦了

驱逐技师

发表于 2022-5-16 10:39:37 | 显示全部楼层
非常感谢

战列舰长

发表于 2022-5-25 11:09:43 | 显示全部楼层
辛苦了

巡洋大副

发表于 2022-6-11 10:24:56 | 显示全部楼层
感谢大佬的汉化分享!

巡洋大副

大三等圆帝国的大总统

发表于 2022-6-19 11:30:46 | 显示全部楼层

多谢分享

巡洋大副

发表于 2022-7-12 00:37:48 | 显示全部楼层
感谢!鞠躬~

驱逐技师

发表于 2022-8-13 11:48:24 | 显示全部楼层
感谢~~~~!

战列舰长

发表于 2022-9-10 12:32:33 | 显示全部楼层
感谢

驱逐技师

发表于 2022-9-17 16:46:16 | 显示全部楼层
感谢大佬分享

驱逐技师

发表于 2022-9-18 21:22:24 | 显示全部楼层
感谢大佬分享

驱逐技师

发表于 2022-10-9 15:05:41 | 显示全部楼层
感谢大佬分享

驱逐技师

发表于 2022-11-1 22:58:55 | 显示全部楼层
装了 启动游戏会崩溃

巡洋大副

发表于 2022-11-12 12:12:51 | 显示全部楼层
装了启动一点mod就报错崩溃了 image.png

驱逐技师

发表于 2022-11-15 13:36:54 | 显示全部楼层
感谢分享

巡洋大副

发表于 2023-1-8 08:18:55 | 显示全部楼层
6666

战列舰长

发表于 2023-1-8 10:24:56 | 显示全部楼层
新版本的magiclib 0.45.2不兼容目前最新版本的seeker0.51,求上一个汉化版本0.42的文件,谢谢。

巡洋大副

发表于 2023-1-10 19:18:56 | 显示全部楼层
最新版不兼容seeker船包

势力巨擘

译码专家

发表于 2023-1-10 19:50:10 | 显示全部楼层
改一下seeker的modinfo里的magiclib版本号就行

点评

谢谢,我知道了,就是把你说的这个文件里面 版号改成 一样的 0.45.2  详情 回复 发表于 2023-1-11 00:34
要弄成什么样呢?我也是说不支持SEEKER,直接禁 用了。  详情 回复 发表于 2023-1-11 00:29

势力巨擘

发表于 2023-1-11 00:29:37 | 显示全部楼层
WHATtHEHECK 发表于 2023-1-10 19:50
改一下seeker的modinfo里的magiclib版本号就行

要弄成什么样呢?我也是说不支持SEEKER,直接禁 用了。

势力巨擘

发表于 2023-1-11 00:34:36 | 显示全部楼层
本帖最后由 尾焰 于 2023-1-11 00:42 编辑
WHATtHEHECK 发表于 2023-1-10 19:50
改一下seeker的modinfo里的magiclib版本号就行

不能说我把SEED的那个改成  0.45.2  的版本号了,还是进不了游戏

点评

[attachimg]25956[/attachimg]  详情 回复 发表于 2023-1-11 01:01

势力巨擘

译码专家

发表于 2023-1-11 01:01:19 | 显示全部楼层
尾焰 发表于 2023-1-11 00:34
不能说我把SEED的那个改成  0.45.2  的版本号了,还是进不了游戏

Seeker.png

点评

对啊,我就是下了最新的 M前置MOD后,又把SEEK的改成了 0.45.2 还是进不去  详情 回复 发表于 2023-1-11 01:23

势力巨擘

发表于 2023-1-11 01:23:35 | 显示全部楼层

对啊,我就是下了最新的   M前置MOD后,又把SEEK的改成了   0.45.2


还是进不去


然后我又改回来,又重新下了  M前置MOD  和   SEEK的  MOD,又进不去,我要死了。。。。。。。我全改回来了

点评

看看你的错误报告,我的就能进  详情 回复 发表于 2023-1-11 01:42

势力巨擘

译码专家

发表于 2023-1-11 01:42:37 | 显示全部楼层
尾焰 发表于 2023-1-11 01:23
对啊,我就是下了最新的   M前置MOD后,又把SEEK的改成了   0.45.2

看看你的错误报告,我的就能进

点评

是进 0.45.2 文件 的 mod_info.json 吧。改成0.45.2 这是游戏日志: [游戏日志] 147622 [Thread-3] INFO com.fs.graphics.TextureLoader - Cleaned buffer for texture graphics/swp/normal/ships/swp  详情 回复 发表于 2023-1-11 01:59
我要疯了,重新下了 下面旧的M前置MOD 和 SEEK的 MOD,连旧的也进不去,我要死了 早知道不手贱了,之前玩得好好的。  详情 回复 发表于 2023-1-11 01:51

势力巨擘

发表于 2023-1-11 01:51:03 | 显示全部楼层
WHATtHEHECK 发表于 2023-1-11 01:42
看看你的错误报告,我的就能进

我要疯了,重新下了  下面旧的M前置MOD  和   SEEK的  MOD,连旧的也进不去,我要死了


早知道不手贱了,之前玩得好好的。

势力巨擘

发表于 2023-1-11 01:59:56 | 显示全部楼层
WHATtHEHECK 发表于 2023-1-11 01:42
看看你的错误报告,我的就能进

是进   0.45.2   文件 的   mod_info.json   吧。改成0.45.2


这是游戏日志:

[游戏日志]

147622 [Thread-3] INFO  com.fs.graphics.TextureLoader  - Cleaned buffer for texture graphics/swp/normal/ships/swp_archer_dd_normal.png (using cast)
147626 [Thread-3] INFO  com.fs.graphics.TextureLoader  - Cleaned buffer for texture graphics/swp/normal/ships/swp_archon_normal.png (using cast)
147633 [Thread-3] INFO  com.fs.graphics.TextureLoader  - Cleaned buffer for texture graphics/swp/normal/ships/cathedral/swp_cathedral_core_normal.png (using cast)
148151 [Thread-3] ERROR com.fs.starfarer.combat.CombatMain  - java.lang.OutOfMemoryError
java.lang.OutOfMemoryError
        at sun.misc.Unsafe.allocateMemory(Native Method)
        at java.nio.DirectByteBuffer.<init>(DirectByteBuffer.java:127)
        at java.nio.ByteBuffer.allocateDirect(ByteBuffer.java:311)
        at org.lwjgl.BufferUtils.createByteBuffer(BufferUtils.java:60)
        at com.fs.graphics.TextureLoader.super(Unknown Source)
        at com.fs.graphics.TextureLoader.super(Unknown Source)
        at com.fs.graphics.TextureLoader.super(Unknown Source)
        at com.fs.graphics.TextureLoader.super(Unknown Source)
        at com.fs.graphics.oOoO.o00000(Unknown Source)
        at com.fs.starfarer.settings.StarfarerSettings$1.loadTexture(Unknown Source)
        at org.dark.shaders.util.TextureData.readTextureDataCSV(TextureData.java:220)
        at data.scripts.SWPModPlugin.initGraphicsLib(SWPModPlugin.java:152)
        at data.scripts.SWPModPlugin.onApplicationLoad(SWPModPlugin.java:179)
        at com.fs.starfarer.loading.ResourceLoaderState.init(Unknown Source)
        at com.fs.state.AppDriver.begin(Unknown Source)
        at com.fs.starfarer.combat.CombatMain.main(Unknown Source)
        at com.fs.starfarer.StarfarerLauncher.o00000(Unknown Source)
        at com.fs.starfarer.StarfarerLauncher$1.run(Unknown Source)

==================这是报告内容


### 游戏信息

游戏版本:                0.95.1a-RC6

### 系统信息

操作系统:Microsoft Windows 10 专业版

版本:10.0.17134 暂缺 Build 17134

总可用内存:`15.95G`


**警告:未找到游戏默认Java运行时**


虚拟机参数:java.exe -XX:CompilerThreadPriority=1 -XX:+CompilerThreadHintNoPreempt -Djava.library.path=native\\windows -Xms6144m -Xmx6144m -Xss2048k -classpath janino.jar;commons-compiler.jar;commons-compiler-jdk.jar;starfarer.api.jar;starfarer_obf.jar;jogg-0.0.7.jar;jorbis-0.0.15.jar;json.jar;lwjgl.jar;jinput.jar;log4j-1.2.9.jar;lwjgl_util.jar;fs.sound_obf.jar;fs.common_obf.jar;xstream-1.4.10.jar -Dcom.fs.starfarer.settings.paths.saves=..\\saves -Dcom.fs.starfarer.settings.paths.screenshots=..\\screenshots -Dcom.fs.starfarer.settings.paths.mods=..\\mods -Dcom.fs.starfarer.settings.paths.logs=. com.fs.starfarer.StarfarerLauncher

堆栈初始大小(`-Xms`):`6144m`

堆栈最大大小(`-Xmx`):`6144m`


### Mod信息

|Mod名称                           |Mod版本   |已启用     |
|-|-|-|
|LazyLib                         |2.7b    |是       |
|zz GraphicsLib                  |1.6.1   |是       |
|MagicLib                        |0.45.2  |是       |
|[C](扩充)更多的船体插件More HullMods 1.11.1|1.11.1  |是       |
|[PD plus] 更多防空                  |0.0.3   |是       |
|[SAD]血腥无政府主义者                   |1.2     |是       |
|A New Level of Confidence       |40 2.1  |是       |
|ac alice ship pack              |0.4a    |是       |
|Apex设计集团                        |1.1.0b  |是       |
|CK 工业                           |2.0.2   |是       |
|FlanshwrightLib                 |0.4a    |是       |
|FSF军事公司[a111164_ExtendPack]     |3.12rc5 |是       |
|Gensoukyou Manufacture [幻想工造]   |0.6.2_rc5, in dev|是       |
|Gia机娘头像包                        |1.0.4   |是       |
|Grand.Colonies                  |1.0.d   |是       |
|GUPPP                           |1.0     |是       |
|Hiigaran Descendants            |2.1     |是       |
|Industrial.Evolution            |3.0.e   |是       |
|J GEEK Federation               |0.6.8   |是       |
|MOD溯源[WhichMod]                 |1.2.1   |是       |
|Nes'SAW                         |1.8b    |是       |
|Officer Extension 军官扩展          |0.4.3   |是       |
|Progressive S-Mods              |0.8.7   |是       |
|prv 星工场                         |v25.1   |是       |
|prv的左径船包                        |v1      |是       |
|prv的额外内容                        |v3      |是       |
|RC的难度选项                         |0.6.5   |是       |
|Scan Those Gates 人之领巨构扫描器       |1.5.0   |是       |
|Seeker - 未知接触                   |0.51    |是       |
|Slightly Better Tech-Mining 更好的技术挖掘|2.7.3   |是       |
|SpeedUp                         |0.7.2   |是       |
|United Aurora Federation        |0.7.2a  |是       |
|中微子公司:怀旧版                       |1.87-RC3|是       |
|人之领历史学会[Domain Historical Society]|0.3a    |是       |
|俘虏船员军官Capture Officers and Crew |1.0.4   |是       |
|内置船插增益 [Better Deserved S-Mods] |1.5     |是       |
|凯尔捷夫技术官僚                        |1.9     |是       |
|势力争霸 [Nexerelin]                |0.10.6  |是       |
|北极星之首 [Polaris Prime]           |0.3.2   |是       |
|博尔肯基金会 [Foundation Of Borken]   |0.5.4   |是       |
|卡特贸易公司(CFT)                     |1.0     |是       |
|卢德拓展 [Luddic Enhancement]       |1.2.5l  |是       |
|可视化维修进度 [Visualized Repair Progress]|0.1.4   |是       |
|咸肝烧酒阿鲁(Warship Girls)头像包        |1.3     |是       |
|地貌改造 & 空间站建设                    |8.1.4   |是       |
|外环带联盟  Outer Rim Allience       |0.94rc1 |是       |
|大豆船包(BigBeans Ship Compilation) |0.1.97  |是       |
|女武神组织 [Valkyrians]              |3.0.0   |是       |
|恶魔航电 [Diable Avionics]          |2.64    |是       |
|战机扩展 - 平衡版                      |1.1.1   |是       |
|扩展纪元拓展                          |1.4.9   |是       |
|星舰传奇 [Starship Legends]         |2.1.2   |是       |
|星际帝国 [Interstellar Imperium]    |2.5.2   |是       |
|未知星域[Unknown Skies]             |0.43    |是       |
|标量科技解决方案                        |0.8.5   |是       |
|格里佩普和莫里亚蒂保安局                    |0.9.8a  |是       |
|楼兰军工综合体                         |1.6.6   |是       |
|泰兰船包                            |0.8.666 |是       |
|海盗拓展 [Underworld]               |1.7.1   |是       |
|海鲜船包 [Seafood Shipworks]        |0.0.7f  |是       |
|火炬舰队与死亡军武                       |0.16rc2 |是       |
|烤乳猪船包0.95适配版                    |1.3     |是       |
|燃料虹吸[Fuel Siphoning]            |1.2.0   |是       |
|穿越者设计局 [Traverser Design Bureau]|1.2.0   |是       |
|红条骑士团                           |1.0     |是       |
|罗伊德联盟Roider Union               |1.4.4   |是       |
|羊头航务局-军备计划[Goat_Aviation_Bureau]|0.5.4   |是       |
|自动指令                            |1.1a    |是       |
|航母现代化-改S                        |1.1.0a  |是       |
|航母现代化扩展                         |1.3.7b  |是       |
|舰船/武器拓展 [Ship/Weapon Pack]      |1.13.0  |是       |
|蓝海渔业[BlueSeaFisher]             |0.98a2.6|是       |
|补漏措施                            |v 1.2.2 |是       |
|装配Li解 [Variant Acknowledged]    |0.2.2   |是       |
|角斗士协会[GladiatorSociety]         |1.3(beta)|是       |
|详细战斗报告[Detailed Combat Results] |5.2.1   |是       |
|赏金拓展 [Bounties Expanded]        |0.3.3C  |是       |
|趋光拓展 [ApproLightPlus]           |0.5.5   |是       |
|趋光议会 [ApproLight]               |1.1.0   |是       |
|达索-米高扬设计局                       |1.6a    |是       |
|锡罕帝国 [Xhan Empire]              |2.4 千眼  |是       |
|阿卡涅西斯之遗                         |v1.9.11 |是       |
|麦哲伦保护国                          |1.5a    |是       |
|黑石船坞 [Blackrock Drive Yards]    |0.9.5b2 |是       |

(以上内容由 远行星号 报错信息收集工具 自动生成,生成工具版本 `1.1.2`).

点评

https://www.fossic.org/thread-30-1-1.html OutOfMemoryError  详情 回复 发表于 2023-1-11 02:23

势力巨擘

发表于 2023-1-11 02:12:24 | 显示全部楼层
新版本的magiclib 0.45.2不兼容目前最新版本的seeker0.51,求上一个汉化版本0.42的文件

势力巨擘

译码专家

发表于 2023-1-11 02:23:20 | 显示全部楼层
尾焰 发表于 2023-1-11 01:59
是进   0.45.2   文件 的   mod_info.json   吧。改成0.45.2

https://www.fossic.org/thread-30-1-1.html
OutOfMemoryError

战列舰长

发表于 2023-1-15 23:00:55 | 显示全部楼层
把SEEK的mod_info.json改成0.45

巡洋大副

发表于 2023-2-3 16:36:25 | 显示全部楼层
image.png
请问这种情况是什么问题,一点mods就报错,抗锯齿已经关了

势力巨擘

发表于 2023-2-6 05:41:34 | 显示全部楼层
请问这个模组的文本是完全拆分开不在内核中的吗,想换回旧版本但没备份,下了个旧英文版……
想把现在的部分文件粘进去看看

势力巨擘

发表于 2023-2-12 13:19:16 | 显示全部楼层
0.46版本的改版本号也无法兼容之前的mod 如高达uc 罗伊德联盟 和seek 有办法解决吗大佬

点评

"version": "0.46.0"前面加#,就相当于把版本号注释掉了,就可以了  详情 回复 发表于 2023-2-15 06:41

巡洋大副

发表于 2023-2-12 13:46:02 | 显示全部楼层
image.png 啥原因?

点评

我就光放了仨前置,试运行就这了  详情 回复 发表于 2023-2-12 13:46

巡洋大副

发表于 2023-2-12 13:46:35 | 显示全部楼层

我就光放了仨前置,试运行就这了

点评

老哥,用这个前置不能开游戏自带的抗锯齿的  详情 回复 发表于 2023-2-12 20:32
*滑块验证:

本版积分规则

Archiver|手机版|小黑屋|远行星号中文论坛

GMT+8, 2024-4-17 00:01

Powered by Discuz! X3.5

© 2001-2077 Tencent Cloud | Durian Software Studio

快速回复 返回顶部 返回列表