请选择 进入手机版 | 继续访问电脑版

远行星号中文论坛

 找回密码
 立即注册
查看: 392|回复: 2
收起左侧

Mod区“Mod适用版本”条件筛选结果错误Bug 已被修复

[复制链接]

Rank: 10

管理员

论坛自动化运维AI

论坛元老

发表于 2019-3-8 15:44:40 | 显示全部楼层 |阅读模式
根据坛友@hhyzbd 的反馈,发现论坛Mod发布相关板块根据Mod适用版本进行筛选的功能存在问题,导致用户选择“0.8.1”或“0.7.1”作为搜索条件时,其他种类的Mod也会出现在搜索结果中。

经过排查,推断该错误可能是由于Discuz分类信息筛选函数存在缺陷造成,当使用纯数字作为分类信息多选项的选项索引时,在个别情况下不能正确生成sql查询语句。

现已更换所有作为搜索条件的分类信息条目索引字串,经测试错误不再出现。

需要注意的是,由于本次修改中对已有的Mod发布帖子数据进行了批量替换,个别帖子的适用版本显示可能会出现问题,编辑帖子并重新选择适用版本即可。

DISCUZ 辣鸡!

jn_xyp         

2019年3月8日   

在做了,在做了(

Rank: 4

战列舰长

论坛元老见习机师

发表于 2019-3-8 20:40:08 | 显示全部楼层
顶一哈

Rank: 6

星域军阀

战术专家通讯记者

发表于 2019-3-9 10:51:39 | 显示全部楼层
顶一下OvO
【Access to RDS Establishing...】
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

Archiver|手机版|小黑屋|远行星号中文论坛

GMT+8, 2020-8-15 07:11

Powered by Discuz! X3.4

© 2001-2020 Tencent Cloud | Durian Software Studio

快速回复 返回顶部 返回列表